Te llamamos

Rellena los datos y te devolvemos la llamada lo antes posible.

* Dentro de horario de oficina

¿Qué buscas?

PHP 5.6 HARÁ PELIGRAR TU WEB EN 2019

PHP 5.6 HARÁ PELIGRAR TU WEB EN 2019

Que título tan alarmista ¿es tanto como parece? Para entender la importancia o gravedad del asunto lo primero es incidir sobre que trata PHP. Es el centro neurológico de nuestra web, es lo que hace que nuestra página pueda mostrar toda suerte de bondades y que a simple vista no se ve, en resumidas cuentas es el lenguaje informático que facilita a los desarrolladores las herramientas para hacer una web funcional. ¿Si no tenemos PHP no podemos hacer nada? Al contrario, pero veríamos nuestras acciones muy limitadas; si hacemos caso omiso del PHP tendremos nuestra página y en ella podremos desde imágenes hasta texto pero careceremos de otras facultades. Este lenguaje de scrypting proporciona las herramientas necesarias para que nuestro sitio pueda incluir cosas tan importantes como las contraseñas de los usuarios o estos mismos, por lo tanto imaginad que sucedería si todos los que utilizan este lenguaje de programación no fuesen conscientes de que en muy poco tiempo dejará de actualizarse y podría convertir en un objetivo claro de ataques informáticos.

El 31 de Diciembre de este año es la fecha límite para que todos los poseedores de PHP 5.6 reciban actualizaciones en forma de soporte, eso se traduce en que no habrá más seguridad para sus servidores y tecnologías homólogas.
Wordpress es uno de los sitios para gestionar contenidos más utilizados hoy día (gracias a él estoy escribiendo esto) y dado su importancia en el sector y conocedores de este problema que se avecina, el soporte de WordPress instan a que se obvie esta versión y se pase directamente a PHP 7.2
Aún con esta advertencia puesta en liza no han bloqueado el uso del PHP 5.6, es más, las anteriores versiones siguen siendo posibles de utilizar aunque están muy desactualizadas y no tienen ninguna protección. Por lo tanto queda en manos del desarrollador estar pendiente de esto y solucionarlo por él mismo.
Lo que son conocedores de su PHP y siguen utilizando la versión 5.6 se estarán preguntando porque de esta decisión tan contundente y para eso tenemos que remontarnos al 2014. El verano de ese año fue el elegido para lanzar dicha versión, con lo cual estamos hablando de un modo que tiene ya más de cuatro años, pero es que además el soporte que le daban a PHP 5.6 de forma constante cesó el pasado año, por lo tanto es lógico que quieran rematar la faena y cesarlo completamente a finales de este año y para ello la mejor forma de “obligar” a sus usuarios a dar el salto es eliminar el soporte de seguridad.

                    EL 31 DE DICIEMBRE DE 2018 PHP 5.6 DIRÁ ADIÓS A SU SOPORTE DE SEGURIDAD

Para los que estén corriendo en eliminar 5.6 para pasarse a la última versión (la 7.2) deberían apuntar en sus agendas personales que esta tendrá el soporte de seguridad activo hasta 2020, así que no os pase lo mismo que con esta y os coja en el último momento.
Hay un problema que puede darse si no quieres dar el salto ahora mismo y piensas apurar hasta el último momento para darlo y es que si lo dejas de ir y se te acaba olvidando cambiarlo, puedes verte en una situación un tanto desagradable. La mayoría de desarrolladores (no todos) por comodidad siguen utilizando las versiones antiguas de PHP porque les funciona relativamente bien, pero conocedores del gran porcentajes de usuarios que hacen uso de esta versión y sabedores también de que en nada perderá su protección, los hackers se verán atraídos como un barco al faro que se encuentra en el mar y aprovechar todos los puntos vulnerables que se abrirán a partir del 31 de Diciembre de 2018.
2 meses y 3 días es la fecha límite, así que si no quieres verte en un problema que luego te cueste solucionar, no esperes hasta el último momento y empieza ya a ponerte manos a la obra.